Probleme mit DNxHD mov Dateien von DaVinci in Premiere

    Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

    Wer eine gezielte Frage hat, der sollte immer daran denken, dass es für eine Antwort wichtig ist, die Computerkonfiguration und auch die Softwareeinstellungen von DaVinci Resolve mit anzugeben. Das erleichtert und eine Antwort könnte auch schneller gegeben werden.

    • Probleme mit DNxHD mov Dateien von DaVinci in Premiere

      Irgendwie kommt Premiere nicht mit den aus Davinci erstellten Dateien klar. Meine Vorgehensweise ist folgende. Ich hatte mpg-Dateien, die in Davinci nicht zu öffnen waren. Diese habe ich in Premiere geöffnet und als mov (DNxHD) ausgegeben. Nach der Bearbeitung habe ich die von Davinci mit den gleichen Parametern wie in Premiere rendern lassen. Nun konnte ich diese aber in Premiere nicht mehr öffnen. Wenn ich 20 Clips importiert hatte, funktionierten ein paar und bei anderen sagte Premiere die hätten keinen Video- und keinen Audio-Stream. Alle Temp-Daten und Cache gelöscht und nochmal probiert, gleicher Fehler, aber Dateien die vorher nicht gingen, gingen nun und der Fehler kam bei Anderen. Im Netz gibt es ein paar Ausführungen zu diesem Bug aber so richtig helfen die Workarounds nicht. Einer ging dann aber und zwar habe ich die Dateien von Davinci nochmal mit einem Konverter (Hybrid) in dasselbe Format gerendert und diese Dateien funktionieren wieder ohne Probleme. Auch die ursprünglichen Dateien aus Premiere ließen sich erneut in Premiere importieren.

      Hat jemand eine Idee, was Davinci beim Rendern von Dateien mit DNxHD als Codec anders macht als Premiere oder Hybrid? Ich habe es auch als Premiere XML Export versucht, da ist es dasselbe Problem. Die Timeline lässt sich in Premiere öffnen aber die Dateien laden nicht. Wenn ich dann die mit exportierten Datein ohne umzubenennen nochmal durch Hybrid laufen lasse, dann funktioniert es erst. Ich werde parallel noch ein bißchen probieren.

      Achso Premiereversion ist CS6. Eine alte von der Arbeit »geerbte« Version, die mir aber reicht.
    • An der alten Version könnte es aber liegen.
      Auch Avid entwickelt seine Codecs weiter (wenn auch oft sehr spät), und DNxHD ist im Grunde schon veraltet, weil es nicht mal 4K kann. Jetzt ist DNxHR üblich. Wenn Du unbedingt noch zwischen Resolve und Premiere tanzen möchtest, probier mal Cineform, ist auch ein sehr guter Zwischencodec.
      DaVinci Resolve Studio 15, iMac 27" 2017, 32 GB RAM, Radeon Pro 580, 8 GB VRAM
      :) Altglas-Fan
    • Aber Avid entwickelt die Codecs doch nicht nur für Davinci weiter. Sämtliche Dateien funktionieren ja. Die aus Premiere gerenderten, die mit Hybrid konvertierten und auch die vom Ninja Blade. Ausschließlich die aus Davinci gerenderten Dateien gehen nicht. Aber DNxHR werde ich mal probieren. Mit dem Switchen ist so eine Sache. Ich habe gerade wieder ein paar Urlaubsvideos zu schneiden und bekam 8 DVDs, also aus einem DVD-Camcorder. Dazu eine DVD die Derjenige selbst erstellt hatte. DVD-Camcorder ausgespielt auf eine VHS-DVD-Recorder-Kombination und dann schön in der VHS-Qualität auf DVD. Das ganze soll am Ende wieder auf eine DVD. Für MPEG-2 in SD funktioniert die Kombination Premiere – Encore hervorragend. Ich wollte aber probieren, ob sich an dem VHS-Teil ein bißchen was verbessern lässt. Ich probiere gerade mit dem Denoiser von Neat rum und da hatte ich bei einem anderen alten Video noch ein bißchen was machen können. Und die Probleme, die ich in Resolve mit der Audiobearbeitung habe, lassen mich auch immer wieder zu Adobe greifen. Ich mache aus meinem Übergang zu Resolve einen ganz gemütlichen Übergang. Aber wie gesagt, DNxHR und Cineform probiere ich mal aus.
    • Hmm, wenn der Codec nicht implementiert wäre, dann dürfte das ja gar nicht funktionieren. Ich arbeite aber im HD-Bereich nur mit diesem Codec, auch in CS6. Der Fehler betrifft ausschließlich mit DR erstellte Dateien. Alle anderen DNxHD Dateien machen kein Problem. Im Übrigen kommt der Fehler auch bei DNxHR und Cineform (gerade probiert aber wenn ich das richtig sehe, ist das auch speziell für 4K gedacht).
    • Ist auch richtig. Avid bietet den Codec zum freien Download an. Ich nehme an, das hast du instaliert.
      Das gleiche Problem bekommst du auch, wenn du Dateien von einem Premiere CC Projekt bekommst.
      Ich hab vor einem Jahr das Colorgrading für einen Film gemacht. Hab dafür die Dateien in DNxHR Format aus Premiere CC gerendert bekommen.
      Keine Chance diese in Premiere CS6 zu öffnen.
      Habs dann direkr ins DR importiert und später mit einer XML exportiert.
      Die konnten das dann ohne Problemme mit Premiere CC weiterbearbeiten.
    • XML macht eigentlich gar nichts. Das ist nur eine Auszeichnungssprache, wo vereinfacht gesagt, in einer Textdatei drinsteht, wie ein Programm das Projekt aus einem anderen Programm wieder zusammenbauen soll und die gerenderten Dateien dazu werden mitgeliefert. Die gerenderten Dateien unterscheiden sich aber nicht von denen, die man ohne XML rendert. Bei Dateien aus anderen Adobe-Produkten habe ich das Problem auch gar nicht. Irgendetwas macht DaVinci anders beim Rendern. Ich habe da aber auch noch das nicht mehr supportete Quicktime auf dem Schirm. Bei älteren Fragen im Netz zu ähnlichen Problemen hatte es nämlich noch geholfen, die letzte Quicktime-Version zu installieren.

      Hab gerade noch etwas festgestellt. Wenn ich einen fehlerhaften Importversuch in Premiere hatte, kann ich danach die Codec-Einstellungen für das Rendern nicht mehr aufrufen. Das klappt erst nach einem Neustart wieder.

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Horst Girtew ()

    • Klappt auch nicht. Weder mit OP-Atom noch mit OP1A. Ich habe jetzt mal mit MediaInfo nach Unterschieden gesucht. Zunächst mal sind es die kodierende Programme:

      Resolve: Lavf57.25.100
      Hybrid: FFmbc 0.7

      Da sich das Ganze ja mit einer Neukodierung in Hybrid beheben lässt, glaube ich nun doch auch eher an sowas wie fehlende Headerdaten oder noch wahrscheinlicher Headerdaten mit denen Premiere nix anfangen kann, weil die zu einer neueren Generation gehören und Premiere die dann fehlinterpretiert. Ich vermute mal, man kann Resolve nicht dazu bringen ffmpeg Kodierer zu benutzen.
    • Ich tippe auch auf die veraltete PP Pro CS6 als Problem. Schau mal hier gibt´s eine alte Diskussion von 2014 wo zum Download eines Codec Packs von Avid geraten wird, keine Ahnung ob das heute noch Bestand hat, aber ist vielleicht den Versuch wert.

      Generell solltest du dir natürlich für die Zukunft überlegen, ob du überhaupt noch mit Premiere Pro arbeiten musst, wenn du mit Resolve ein deutlich modernes Programm (als die CS6 Version) kostenlos hast.
      Heiko Thies - Thiesfx.de
      Post Production Specialist

      Mein neuer Kurs:
      Blackmagic Pocket Cinema Camera 4K/6K - Das umfassende Videotraining
      dvd-lernkurs.de/bm-pocket-cine…ssende-videotraining.html
    • Ich würde schon gerne komplett zu Resolve wechseln, aber ich habe da noch Probleme in der Audiobearbeitung. Das funktioniert nicht so ganz, wie ich das von allen anderen Programmen gewohnt bin (Thema Spurlautstärke im »Fader-Kurven-Thread). Und das zweite Problem, wenn man acht Doppel-Mini-Camcorder-DVDs als Quelle bekommt und am Ende auch wieder eine DVD dabei herauskommen soll, dann geht das nicht ohne Drittprogramme und dann bietet sich natürlich das an, mit dem man das vorher immer gemacht hat. Inzwischen hat der Bekannte, für den ich das Meiste mache ja auch einen HD-Camcorder, wenn auch nur 720p aber mit resolve-tauglichen Dateien, nur für das jetzige Projekt hat er nochmal ein paar alte DVDs gefunden, die wir damals noch nicht verwurstet hatten.

      Ansonsten hatte ich ja auch schon die älteren Diskussionen gefunden. Das hatte alles nicht geholfen. Da nehme ich mal an, dass es dieselbe Fehlermeldung war, wenn zum Beispiel damals schon Codecs aktualisiert wurden und/oder eine neue Quicktime-Version herauskam. Da bin ich aber sowohl mit Quicktime, als auch mit den Avid-Codecs auf dem aktuellen bzw. letztmöglichen Stand. Wenn nun wieder irgendwas erneuert wurde, aber das nicht mehr supportete Quicktime auf seinem alten Stand bleibt, kann da natürlich der Hase im Pfeffer liegen.

      Das nächste Problem ist, dass ich die Intensity-Karte eingebaut habe, dafür das Mainboard wechseln (lassen) mußte und danach das Adobe Paket neu installieren. D.h. zum Einen eine umfangreiche Hardwareänderung, Chipsatz etc. und softwareseitig auch komplett neu installiert und da weiß man natürlich auch nicht mehr im Detail, was man damals an zusätzlichen Plugins alles installiert hat, wenn man mal einen Fehler hatte. Zumindest macht es die Fehlersuche schwieriger.

      Hab jetzt nochmal andere Dateien probiert. h264 als mp4 funktioniert, h264 als mov nicht, womit dieses Problem schonmal Richtung Quicktime geht.


      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Horst Girtew ()

    • Hallo, also ich habe für die weitere Bearbeitung von den in Resolve geschnittenen DNxHD-mov-Dateien, die sich andernfalls überhaupt nicht in CS6 importieren ließen, den obengenannten Avid-LE-Codec installiert, seitdem kann ich die Dateien problemlos in Encore CS6 importieren, allerdings hakt es gelegentlich, sodass ich den Codec immer mal wieder "reparieren" lasse. Dies jedenfalls nativ unter Win8.1. (Mit Encore CS6, welches mit geringen Aufwand auch mit "Wine" unter Linux läuft, habe ich unter Linux diesen Effekt übrigens nicht, dort brauchte ich den Avid-Codec nur einmal installieren).

      Soeben konnte ich dasselbe unter Premiere CS6 nachstellen. Erst nach erneuter Reparatur des Avid-LE-Codecs lässt sich es dann aber problemlos importieren. Dateien sind direkt aus Resolve h.264 DNxHD-Dateien höchster Stufe im Apple-MOV Container. Quicktime in Version 7.0.4 (=uralt) ist installiert, sei am Rande erwähnt, müsste Adobe direkt mitgeliefert haben.

      Du hast Win10 - läuft diese "alte" Adobe-Software denn insgesamt noch flüssig unter Win10 oder gibt es da ggf. weitere Einschränkungen, die ursächlich sein könnten?
      Video-PC: AMD Ryzen Threadripper 16-Core, 64 GB DDR4, 2x NVidia GeForce GTX1080 Ti 11GB, 1TB NVMe, 2TB SSD, 2x 6 TB WD Black, Resolve Studio 17.0 beta unter LinuxMint 20
    • Nachtrag:
      Bei Premiere habe ich nun allerdings Probleme mit der Tonspur: Sie wird erfolgreich importiert und auch angezeigt, allerdings bleibt die Tonspur stumm, die Wellenform ist auch keine solche. Das Problem habe ich unter Encore CS6 hingegen NICHT. Workaround: Ton in Resolve getrennt exportieren ins WAV-Format. Ist ja nur ein Klick mehr...
      Video-PC: AMD Ryzen Threadripper 16-Core, 64 GB DDR4, 2x NVidia GeForce GTX1080 Ti 11GB, 1TB NVMe, 2TB SSD, 2x 6 TB WD Black, Resolve Studio 17.0 beta unter LinuxMint 20
    • Ich habe meinen Workflow geändert und lasse Premiere ganz raus. Das Ziel ist in der Regel ja DVD und da exportiere ich jetzt einfach AVI unomprimiert 720x576 und lasse dann vom 15 Jahre alten TMPGEnc Plus 2.5 eine DVD-konforme Datei draus basteln. Das funktioniert problemlos in Encore bzw. kommt ja jeder DVD-Author damit klar. Audio ist dort nativ wav oder mp2, aber wenn ich gute Laune habe, mache ich extern ac3 draus.