Davinci-Resolve unter Debian-Linux

    Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

    Wer eine gezielte Frage hat, der sollte immer daran denken, dass es für eine Antwort wichtig ist, die Computerkonfiguration und auch die Softwareeinstellungen von DaVinci Resolve mit anzugeben. Das erleichtert und eine Antwort könnte auch schneller gegeben werden.

    Systemvoraussetzungen für die Nutzung von DaVinci Resolve unter Win: Win 10, 16 GB RAM; mit Fusion besser 32 GB____http://www.davinci-resolve-forum.de/wiki/doku.php?id=systemvoraussetzungen

    • Danke Andre,

      hab's so gemacht, aber nach dem Neustart wird immer noch gesagt:»Kernel driver in use: amdgpu«

      Die Treiberverwaltung ist übrigens leer: »»Your computer does not have additional drivers«
      Alexquemelin

      Hardware:
      Desktop-PC: Motherboard AMD-B450M-Pro-M2-V2; CPU: AMD AM4 Ryzen 7 2700 8x; GPU: AMD Radeon RX 580; RAM: 16 GB; HD 1: SSD 240 GB; HD 2: SATA 2 TB; Keine Übertaktung eingestellt
      Software:
      1. Linux CentOS 8; (2. Win 10); Davinci Resolve 16.2.2.3 (Studio-Version); GPU-Treiber: proprietärer Treiber "amdgpu-pro"
    • Hallo Andre,

      ich hab's jetzt mal mit CentOS 8.2. versucht. Auch hier das gleiche Bild: Installation klappte gut, das System läuft einwandfrei. Auch die nachträgliche Installation des proprietären AMD-Driver verlief reibungslos, ebenso wie die Installation von Davinci-Resolve 16.2.3.

      Aber beim Start wird mir mitgeteilt: »Davinci Resolve cannot find any opnecl cabable GPUs.« Ich werde dann aufgefordert zum »update hardware configuration«. Aber da ist beim Versuch einer manuellen Einstellung der GPU nichts zu sehen und bei »auto« kommt der Absturz von DR.

      Aber immerhin: Das ist schon eine andere Interaktion als zuvor bei Debian und Mint.

      Und auch hier vermute ich, dass der Kernel den bei der Systeminstallation installierten offenen Treiber »amdgpu« lädt anstatt den prprietären »amdgpu-pro«. Jedenfalls wird das angezeigt nach »lspci -k | grep -A2 VGA«: Kernel driver in use: amdgpu.

      Ich müsste das wohl ändern, weiß aber nicht wie.

      Herzliche Grüße

      Alex
      Alexquemelin

      Hardware:
      Desktop-PC: Motherboard AMD-B450M-Pro-M2-V2; CPU: AMD AM4 Ryzen 7 2700 8x; GPU: AMD Radeon RX 580; RAM: 16 GB; HD 1: SSD 240 GB; HD 2: SATA 2 TB; Keine Übertaktung eingestellt
      Software:
      1. Linux CentOS 8; (2. Win 10); Davinci Resolve 16.2.2.3 (Studio-Version); GPU-Treiber: proprietärer Treiber "amdgpu-pro"
    • Wollte euch nur kurz mitteilen, dass ich eine Lösung gefunden habe. Zwar nicht für Debian aber für Linux auf meiner Hardwarearchitektur (s.u.).

      Unter CentOS 8.2 hat es jetzt geklappt. Beim ersten erfolglosen Versuch hatte ich bei der Installation des proprietäten AMD-Treibers lediglich das Kommando »sudo ./amdgpu-pro-install« eingegeben. Das hat zwar den Treiber installiert, nicht aber die OpenCL-Komponenten. Ich hätte noch das Argument » --opencl=pal« (bei älteren Karten: --opencl=legacy oder beides) eingeben müssen. Nach einiger Suche kam ich dann auf diese Seite, wo mir klar wurde, dass das zusätzliche Argument wichtig ist. Danach ging alles wie gewünscht.

      Nun arbeite ich zwar mit CentOS anstatt mit Debian und kämpfe mit der Umstellung beim Paketmanagement aber immerhin bin ich froh, dass DR bei mir auf Linux läuft.

      Euch allen vielen Dank für die Unterstützung!

      Alex
      Alexquemelin

      Hardware:
      Desktop-PC: Motherboard AMD-B450M-Pro-M2-V2; CPU: AMD AM4 Ryzen 7 2700 8x; GPU: AMD Radeon RX 580; RAM: 16 GB; HD 1: SSD 240 GB; HD 2: SATA 2 TB; Keine Übertaktung eingestellt
      Software:
      1. Linux CentOS 8; (2. Win 10); Davinci Resolve 16.2.2.3 (Studio-Version); GPU-Treiber: proprietärer Treiber "amdgpu-pro"
    • Hallo Alex,

      das sind doch mal gute Neuigkeiten. Danke auch für die Verlinkung.
      Damit sollte ja auch unabhängig von CentOS eine Lösung gegeben sein. Leider kann ich es mangels AMD-Karte derzeit nicht testen. Sollte sich das ändern, folgt hier eine Info.

      Grüße,
      Cy
      Video-PC: AMD Ryzen Threadripper 16-Core, 64 GB DDR4, 2x NVidia GeForce GTX1080 Ti 11GB, 1TB NVMe, 2TB SSD, 2x 6 TB WD Black, Resolve Studio 16.2.3 unter LinuxMint 20